请选择 进入手机版 | 继续访问电脑版

编译安装cmake

[复制链接]
查看1527 | 回复0 | 2019-7-3 15:55:31 | 显示全部楼层 |阅读模式
一、安装方法

下载cmake:
https://www.51anidea.com/forum.php?mod=viewthread&tid=1097&extra=page%3D1

下载好cmake-3.14.5.tar.gz后,将其上传到服务器上。

# tar -zxvf cmake-3.13.2.tar.gz -C /usr/local

# cd /usr/local/cmake-3.13.2

# ./bootstrap

# make

# make install


安装完毕之后执行以下命令查看cmake的版本:

# cmake -version



二、故障排查


执行 ./bootstrap 报错:

/usr/local/cmake-3.14.0/Bootstrap.cmk/cmake: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/local/cmake-3.14.0/Bootstrap.cmk/cmake)
/usr/local/cmake-3.14.0/Bootstrap.cmk/cmake: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/local/cmake-3.14.0/Bootstrap.cmk/cmake)


解决方法参考以下链接:https://www.51anidea.com/forum.php?mod=viewthread&tid=1103&extra=page%3D1




上一篇:编译安装gcc-5.4.0
下一篇:rpm安装时提示 Failed dependencies xx conflicts with xx 的解决方法
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则