请选择 进入手机版 | 继续访问电脑版

rpm安装时提示 Failed dependencies xx conflicts with xx 的解决方法

[复制链接]
查看694 | 回复0 | 2019-7-25 10:40:48 | 显示全部楼层 |阅读模式
一、故障现象

在使用rpm安装软件包时,有时会出现报错:
error: Failed dependencies:
  xx conflicts with xx


例如:
  1. # rpm -ivh mysql-community-release-el6-7.noarch.rpm
  2. warning: mysql-community-release-el6-7.noarch.rpm: Header V3 DSA/SHA1 Signature, key ID 5072e1f5: NOKEY
  3. error: Failed dependencies:
  4.         mysql-community-release conflicts with mysql80-community-release-el6-1.noarch
复制代码
在安装mysql-community-release-el6-7.noarch.rpm时,提示 mysql-community-release 与mysql80-community-release-el6-1.noarch冲突了。


二、解决方法

卸载与要安装的软件包产生冲突的软件:
# rpm -e mysql80-community-release-el6-1.noarch

即卸载掉报错信息中 “conflicts with”后面跟的软件包名。




上一篇:编译安装cmake
下一篇:coreseek报错:ERROR: index 'xml': failed to configure some of the sources, will not index.
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则