请选择 进入手机版 | 继续访问电脑版

如何在PHP7.2.22编译安装php-yaml

[复制链接]
查看1270 | 回复3 | 2019-9-14 08:41:50 来自手机 | 显示全部楼层 |阅读模式
如题
需要重新编译php7.2.22吗




上一篇:Ubuntu如何编译安装PHP7.2.22和Pthreads?
下一篇:docker上面如何安装compares
回复

使用道具 举报

admin | 2019-9-14 08:46:00 来自手机 | 显示全部楼层
安装依赖包
sudo apt-get install libyaml-dev
下载源码
# wget https://pecl.php.net/get/yaml-2.0.4.tgz
编译
# tar zvxf yaml-2.0.4.tgz
# cd yaml-2.0.4
# phpize
找到你的pho-config文件 替换下
# ./configure --with-php-config=/www/server/php/72/bin/php-config
# make
# make install
编辑 php.ini文件
extension = yaml.so
验证
php -m | grep yaml
输出 yaml 表示成功
回复 支持 反对

使用道具 举报

junxiesky | 2019-9-14 08:53:58 来自手机 | 显示全部楼层
admin 发表于 2019-9-14 08:46
安装依赖包
sudo apt-get install libyaml-dev
下载源码

已解决
感谢大佬,中秋快乐
回复 支持 反对

使用道具 举报

admin | 2019-9-14 08:55:18 来自手机 | 显示全部楼层
junxiesky 发表于 2019-9-14 08:53
已解决
感谢大佬,中秋快乐

同乐同乐
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

2

主题

33

帖子

330

积分

中级会员

Rank: 3Rank: 3

积分
330